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1 Introduction to the Emory Normal Database Generator (ENDG)

Before You Begin

Emory Normal Database Generator (ENDG) is a software application 
which enables you to create your own normal database for use with the 
Emory Cardiac Toolbox. A normal database, sometimes called a “normal 
file”, is used inside Emory Cardiac Toolbox to compare to a clinical patient 
study. Areas of the patient study which are significantly reduced in counts 
compared to the corresponding area of the normal file, are considered 
abnormal, and appear as blackened areas on a Defect Extent polar map.

This document contains important information you need to know before 
using the Emory Normal Database Generator application, including 
warnings, errors, and limitations, as well as information on how to use this 
manual. 

In this user manual, the program will often be referred to by its acronym, 
ENDG.

It is assumed that you have a working knowledge of nuclear medicine and 
are familiar with the operation of your Computer System.

About this Manual

Throughout this manual, the Emory Normal Database Generator 
application will also be referred to as ENDG. the following conventions are 
used to distinguish elements of text:

Caution: This is an example of the way cautions will appear in the manual. 
Cautions are used to alert you to situations that could result in damage to 
the system hardware or software.

Note: This is an example of the way notes will appear in the manual. Notes 
provide additional information about the current process or procedure, as 
well as parenthetic information regarding operation procedures.

Underlined text is used to introduce a numbered sequence of steps that the 
user is to follow.

Conventions
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Bold Text is used for section and sub-section headings. In addition, 
buttons and menu items that appear in ENDG are discussed using their 
labels--the exact text the user sees--and these are bolded within the text of 
this manual.

In the text of the manual, we will describe how the user should interact with 
the computer, as follows:
• “Left-click” means press the left-most mouse button while the cursor is 

on the indicated button or other part of the screen.
• “Right-click” means press the right-most mouse button while the cursor 

is on the indicated button or other part of the screen.

The chapters in this manual are organized as follows:
• Chapter 1, Introduction, provides information about the manual, as well 

as important information you need to know, before using the ENDG 
application.

• Chapter 2, Using the ENDG Application, describes all of the processing 
options and features.

• Appendix A, References
• Appendix B, Recommended Protocol Parameters

All illustrations in this manual are representative samples only. While your 
results will be similar in appearance, the data presented will reflect the 
study you are processing.

Throughout the manual, figures are used to illustrate the appearance of 
review screens and user interface elements such as buttons and lists. The 
screens that you see in ENDG may have blue, gray or tan backgrounds, 
depending on the Windows settings of the computer on which the software 
is running. Consequently, the figure background color may not match your 
particular machine.

Computer Interaction

Chapter Contents

About Figures
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2 The Emory Normal Database Generator (ENDG)

Introduction

Creation of a normal file requires certain data to be specifically extracted 
from each patient study that is to be part of the file. This step is 
accomplished in ECToolbox, therefore each patient who is to be part of the 
normal group must first be processed in ECToolbox.

Briefly, the major steps to create a new normal file are as follows:

• Create a new database, or open an existing one.

• Add normal patients to the database.

• Calculate and display the normal distribution of all patients.

• Decide on the threshold for abnormality, to be used when a patient 
is compared to the normal file.

• Export the file for use with Emory Cardiac Toolbox.

To save a file which ENDG can use for building a normal file, follow these 
steps in ECToolbox:

• Select the button NFile PMaps, which is one of the permanent 
buttons on the left side of the screen. This will display the current 
patient’s raw polar maps, and the composite polar maps for the 
currently-selected normal file.

• On the lower left of the screen, under Normal File Options, there are 
two buttons. One, Export To Normal Database, will export the file 
the ENDG needs. The other button, Launch Normal Database 
Generator, will start the ENDG application. The appearance of the 
buttons is shown in Figure 2-1.

Saving Data for 
ENDG
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Figure 2-1. Normal File Option buttons in ECToolbox.

Selecting the Export... button saves a file to the computer’s hard disk, to a 
location inside the ECToolbox (a folder named ENDGData). As the file is 
about to be saved, a dialog is displayed showing the filename that will be 
used. The name can be edited if necessary.
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Buttons and Controls in ENDG

There are several parts to the ENDG window, which are always displayed. 
These basic elements are shown in Figure 2-2, and include menu items, 
buttons, an area for display of images and curve plots, and a status bar.

Figure 2-2. The parts of the ENDG window are highlighted. There is a main menu 
(yellow box), a set of buttons to access the main functions (red box), an image 
display area (blue arrow) and a status bar for text messages (green arrow).
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Most of the user interaction that is necessary in ENDG takes place via the 
main buttons, which activate functions that represent the major steps that 
would be followed in creating and using a normal file.

The menu and main buttons are shown in Figure 2-3. The buttons are 
shown from top to bottom in the approximate sequence in which the steps 
would be performed--opening a normal file, showing its contents, etc. The 
choices in the menu are additional functions, some of which are related to 
the button functions, but providing more details, or giving finer control over 
what the program is doing.

Figure 2-3. The main menu and main buttons for interacting with ENDG.

main buttons
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The buttons have tooltips, meaning that if the mouse cursor hovers over 
the button, a small text box appears, giving a brief hint of the button’s 
function (Figure 2-4).

Figure 2-4. The tooltip hint for button Export Normal File.

The status bar is an area at the bottom of the window where a single line of 
text is occasionally displayed by the program. This is a message to the 
user, usually reporting the results of some action, as when a file has been 
saved to disk. See Figure 2-5 for an example.

Figure 2-5. The status bar. In this example, the program is reporting that a file was 
saved as intended. If the File Save operation had failed, the message would be 
different.
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Managing Normal Files

The first step after ENDG starts is to select a normal file to work with. If the 
file already exists and you want to modify it in some way, then the file just 
has to be selected from a list. If you are just starting to work with the file, 
then it will have to be created.

To create a new normal file in ENDG, select the New Normal File button. 
The form shown in Figure 2-6 will be displayed. The form is in three 
sections, and asks the user to make several choices.

• The name of the new normal file. This can be any name desired, 
but typically would be descriptive of the type of scan data involved, 
such as thallium or sestamibi, and perhaps the acquisition protocol 
or some other element that distinguishes this file from any other. 
The name entered is the name the file will have when it is selected 
later for use inside ECToolbox.

• How to handle genders. There are two buttons here: Separate will 
indicate that you intend to create a normal file for females and 
another file for males. Combined indicates the intention to combine 
males and females into a single file. A combined file would be 
created, for example, if there was accurate attenuation correction or 
some other factor that would cause gender-related image 
differences to be minimal.

• Which gender group to work with initially. You must select to work 
with male data or female data. If the normal file is of the gender-
combined type, it doesn’t matter which group you select to work 
with.

Selecting a File to 
Work With
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Figure 2-6. The form for describing the new normal file that is about to be created.

To select an existing file, use the Open Normal File button. The dialog 
shown in Figure 2-8 will be displayed. All of the existing normal files that 
you have previously created will be in the folder “userNormalFiles”. Each 
subfolder has a name corresponding to the normal file name, which was 
entered when the file was initially created--using the form shown in Figure 
2-6. Highlight the folder corresponding to the file you want and select OK.

Note: The Make New Folder button appears on this dialog form, as it 
always does when Windows is waiting for a user’s file selection. Although 
this function can be used, it serves no particular purpose at this point in 
ENDG.
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Figure 2-7. Selecting a normal file to work with. All user-created files are in the 
folder “userNormalFiles”.

Once the desired folder has been selected, you will be asked which 
gender group is to be used first, via the dialog form shown in Figure 2-8. 
The default choice is male. Once this choice is made, the previously-saved 
data for the selected normal file is loaded by ENDG, and the normal file is 
available for examination. If a normal mean was saved, the results will be 
immediately displayed in curve and polar plot formats.
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Figure 2-8. The form for selecting which gender group of data to look at. This 
setting can be changed at any time while working in ENDG.

If you have a separate-gender normal file, and you select to work initially 
with male data, for example, you can switch to female data at any time by 
using the menu choice Options/Select Working Group, which is 
explained below.

The next section discusses all of the menu options in ENDG. Most of these 
have keyboard shortcuts.

The File menu (Figure 2-9) has five options.

• Open XML in Internet Explorer. Use this option to open any XML-
format file for viewing.

• Save Normal File. This option saves the current “state” of the 
normal file that is open. This includes the number of patients, the 
ENDG version in use, the creation date and the mean arrays

• Save Screen. Saves a snapshot of the current screen as a graphic 
file on disk.

• Save and Exit. Saves the current “state” of the normal file and then 
exits the program.

The File Menu
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• Quit--Don’t Save. Exits the program without saving anything.

Figure 2-9. The File menu.

The Database menu (Figure 2-10) has four options. All of these relate in 
some way to the list of patients that comprise the database for the current 
normal file.

• Add Patient(s). Allows a user to add one or more patients to the 
current normal file.

• Delete One Patient. Allows one patient to be deleted from the 
current normal file. See also the later section of this manual: 
“Comparison Screen Options” on page 34.

• Undelete One Patient. Allows one patient that was previously 
deleted to be restored to the current normal file.

• View Patient List. Allows the current patient database to be 
displayed.

The Database Menu
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Figure 2-10. The Database menu.

The Options menu (Figure 2-11) has two options.

• Select Working Group. Allows a user to select which gender group 
to work with. This can be different from the group selected when the 
normal file was first opened or created.

• Save Means as Textfile. Saves a textfile to disk, which summarizes 
the mean values for each sampled pixel in the normal file. For 
details, see “Comparison Screen Options” on page 34.

Figure 2-11. The Options menu.

The Options Menu
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The View menu (Figure 2-12) has three options.

• Mean Profiles.... Displays mean profile curves for stress, rest or 
reversibility. The three choices are accessed through a submenu 
that appears when Mean Profiles... is selected.

• Mean Polar Maps. displays a new window showing the mean and 
standard deviation maps for the current normal file.

• Patient Polar Maps. shows polar maps for all patients in the current 
working group, and their defect extent as compared to the normal 
mean and thresholds.

Figure 2-12. The View menu.

The Help menu (Figure 2-13) has two options.

• Quick Help. This options displays a web page that gives brief 
instructions on using ENDG, including the steps for creating a 
normal file. This web page is found on the local computer, so you 
don’t have to have an active internet connection to view it.

• About ENDG. displays the full name and version of the program.

Figure 2-13. The Help menu.

The View Menu

The Help Menu
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Managing the Patient Database

Normal files are used to highlight perfusion deficits in a patient study by 
providing a normal range to compare against. The terms normal file and 
normal database are often used interchangeably. When we are developing 
a normal file, we have the concept of a patient database, which is the 
collection of patients whose data is used to generate the file. The patient 
database is one component of normal file development, but not the only 
one. We also have to set the thresholds for the normal file, and be aware of 
the mean and standard deviation for different segments of the left ventricle. 
This section of the manual deals with the various aspects of the database--
the collection of patients--how to add to it, delete from it and review the 
contents of it.

Patient studies can be added to the database by selecting Add Patient(s) 
from the Database menu, as shown in Figure 2-10. This menu selection 
causes the program to access a folder where patient data has been saved 
from ECToolbox, for the express purpose of being used in ENDG. See 
“Saving Data for ENDG” on page 11 to review how this works.

Selecting Add Patient(s) causes the patients available from ECToolbox to 
be displayed in a dialog. The dialog is shown in Figure 2-14.

When the dialog is displayed, use the mouse to highlight one or more files, 
and click the Open button. The selected files are immediately moved out of 
the displayed directory and into the Patients directory for the current 
normal file. Once this is completed, a message will be displayed in ENDG’s 
status bar at the bottom of the screen, indicating how many patients were 
imported to the database.

Adding Patients
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Figure 2-14. The dialog that is displayed when Add Patients was selected. The 
files listed, ending in “.xml” are available for import to the current database. Once 
imported, the files will disappear from this directory, and appear in the Patients 
folder of the current normal file.

There are two ways to delete a patient from the current normal file. In 
method one, you will identify a patient you want to delete, perhaps from a 
list of the patients in the file. Make a note of the ID of the patient to be 
deleted, and then select Delete One Patient from the Database menu. 
The dialog window shown in Figure 2-15 will then be displayed.

Enter the patient ID in the first textbox, and click the Accept button. This 
tells ENDG to find a patient with that ID.

Deleting Patients
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Figure 2-15. The dialog displayed in response to the menu choice Database/
Delete One Patient. You can only type into the Patient ID textbox.

If ENDG finds a patient with the indicated ID value, you will see the dialog 
window shown in . If the patient was not found, a message will be 
displayed.

Figure 2-16. The dialog displayed after ENDG has located the patient with 
selected for deletion. In this example, the patient has an ID of “120214”, the name is 
“Rb-F20” and the study date is “6/3/2004”. Note that the Delete button is now 
active.

To actually delete the patient, click the Delete button, which is now active. 

You can also delete patients from the polar plot comparison page. See 
“Comparison Screen Options” on page 34.
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To view the list of patients in the database of the current normal file, select 
View Patient List from the Database menu. In a few moments, a new 
window will open. This is an external application that displays the patient 
database, as shown in Figure 2-17.

Figure 2-17. Displaying the patient list. The yellow arrow points to a small vertical 
line that is the current record indicator.

There are a number of tools included in this window. Briefly, some of the 
main options are:

• A column on the left side showing the number of patients in the 
database (“Total”), the number of patients shown in the window 
(“Found”) and the record number that is current (“Record”). The 
current record is indicated by the small vertical line next to the 
patient name. See the figure above.

Displaying the 
Database
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• small buttons for zooming the display, as shown in Figure 2-18.

• The patient information, displayed in columns. To sort the entire list 
by a particular descriptor such as name or gender, click the column 
header.

Figure 2-18. The database list window has controls for stepping from one patient 
to the next (yellow arrow), and zooming in (green arrow), or out blue arrow).

Figure 2-19. A portion of the database list window. Data can be sorted by any 
column. To sort by patient name, for example, click the column header labeled 
“ptname”.
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Note: Any time the database list window closes, whether automatically 
ENDG exits or because the user manually closed it, an informational 
window will display for about two seconds (Figure 2-20), and then 
disappear.

Figure 2-20. The information box displayed when ENDG’s database list window 
closes.
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Defining the Normal Mean

At any time when there are two or more patients in the database, the mean 
and standard deviation can be calculated by clicking the Show Normal 
File button. The mean +/- 1 standard deviation for each of the 12 profiles in 
the normal file will be displayed. Each profile represents 40 sampled pixels 
from one short axis slice from apex (profile 0) to base (profile 11). An 
example is shown in Figure 2-21.

Figure 2-21. Red curves are mean values, black curves represent one standard 
deviation above and below the mean. Apex is profile 0.

Calculating Means
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The mean curve display characterizes the entire normal file. Sampled 
pixels are on the horizontal axis, and counts on the vertical axis. Sampling 
begins at 45 degrees in the antero-lateral direction when viewing the heart 
from the apex, so the myocardial sections are represented on the curves 
as shown in Figure 2-22, with the anterior quadrant being the first section 
of the curve, followed by septum, inferior wall and lateral wall.

Figure 2-22. Myocardial walls as seen on each profile curve (left): 1=anterior, 
2=septum, 3=inferior, 4=lateral. These correspond to the simple polar map style 
diagram on the right, which is the left ventricle in short axis as seen from the apex..

Be default, the stress mean curves are displayed first. To see the rest 
plots, either click the Next Screen button at the left, or use the View menu 
and select Mean Profiles.../Rest. To return to the stress curves from 
viewing rest or reversibility, use the Prev Screen button (“Previous 
Screen”), or use the View menu. The View menu can be used to recall the 
mean plots of your choice--stress, rest or reverse--at any time while ENDG 
has a valid normal file open. Once the curves are displayed, Next Screen 
and Prev Screen can be used to move between the three sets.

At the same time as the mean curves are displayed, ENDG will display a 
new window showing polar plots representing the mean for the current 
normal file. This display is shown in Figure 2-23. Stress, rest and 
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reversibility mean are shown across the top row, and stress, rest and 
reversibility standard deviation are across the bottom row.

Figure 2-23. Mean and standard deviation polar maps representing the entire 
database of normal patients in the normal file.

The stress and rest maps represent the distribution against which a patient 
map is compared when the normal file is used in Emory Cardiac Toolbox.
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Normal files are used to determine the presence and size of perfusion 
defects in a patient study. Accurate definition of abnormal perfusion 
depends not only on the normal mean values that are present in the file, 
but on the thresholds for abnormality that have been set. Pixels in the 
patient myocardium that fall below the defined threshold are said to be 
abnormal. With a different threshold, that same pixel value may or may not 
be abnormal.

In ENDG, all thresholds are set to zero when a normal file is defined. To set 
thresholds for all regions of the myocardium, select the Set Thresholds 
button. The dialog shown in will be displayed. 

Figure 2-24. Dialog for setting abnormal thresholds

By default, thresholds are set to 2.5 standard deviations for the stress and 
rest polar maps, and reversibility is set to 1.0 std. dev. Any of these values 
can be changed. To save thresholds, click the OK button. The thresholds 
will be saved to a file on disk. To indicate that this operation was 
successful, ENDG displays a message in the status bar at the bottom of 
the screen.

An example of the contents of the threshold file is shown in Figure 2-25.

Setting Thresholds
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Figure 2-25. Contents of the threshold file.
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Comparing Patients to Normal

The current set of patients can be compared to the normal file you are 
developing, just as if they were clinical patients in ECToolbox. To do this, 
select the Compare to Normal File button. This produces a screen similar 
to the one shown in Figure 2-26, with each patient represented by a polar 
map. Areas of the map are blacked out if they differ significantly from the 
mean of all normal patients. Under each map is the ID and Name of that 
patient.

Figure 2-26. Four patients displayed with comparison to the current normal file.

There are several options that can be exercised on the normal comparison 
display. 

A maximum of 3 rows of 7 polar maps are displayed at once. If there are 
more patients than this, you can see the next group by using the Next 
Screen button. Return to earlier patients using the Prev Screen button.

For any displayed polar map, a quantitative summary of the defects that 
are shown in black can be obtained by left-clicking the map. A small 
window will appear (Figure 2-27). Defect extent refers to the size of the 
abnormal black area within the polar map. Note that defect severity and 
reversibility values can only be seen by using the left-click method. To 

Displaying Patient 
Polar Maps

Comparison Screen 
Options
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dismiss the defect summary window, click either the OK or Cancel button, 
or the red “X” close widget in the corner.

Figure 2-27. The defect summary window, which appears when a patient polar 
map is clicked with the left mouse button. Defect severity refers to the total number 
of standard deviations below the mean for every pixel within the blackout area.

As discussed in the section “Deleting Patients” on page 24, you can delete 
a patient from the database while on the Compare screen. You might want 
to do this if, for example, you see a patient with an unusually large defect. 
To delete the patient, click the polar map with the right mouse button. You 
will get a small question dialog. Selecting Yes will delete the patient, and 
draw an “X” through the map. This is a visual indicator that the patient was 
removed from the database, but still allows you to see the map, in case you 
decide to restore the patient. These displays are shown in Figure 2-28 and 
Figure 2-29.
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Figure 2-28. This dialog is displayed when you right-click a polar map while on 
the Compare to Normal File screen. Selecting Yes removes the patient from the 
database.

Figure 2-29. The patient comparison screen after one patient was deleted from 
the database, as indicated by the “X” on that polar map.

Deleting a patient has several effects: the polar map is marked on the 
display, the patient’s record is removed from the current database, and the 
file saved by ECToolbox (from which the patient data was loaded) is 
removed from the normal file’s Patients folder. However, the patient data 
has not disappeared entirely. It is still available to be restored to the 
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database in the future, at your discretion. This operation, which ENDG calls 
“Undelete”, can be used immediately or at a later time when ENDG has 
been opened again. To restore a deleted patient, select Undelete from the 
Database menu. A window will be displayed, listing the patients in the 
Deleted Patients folder. Highlight one and select Open. The Compare 
screen will be re-drawn to include the restored patient’s polar map, which 
no longer has an “X” on it. Note however that the restored polar map may 
not appear in the same place on the display, since the database is resorted 
when a patient is deleted.
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Saving Normal File Results

When a normal file has just been created and named, several objects are 
saved into the userNormalFiles folder on disk. There is a Patients folder, 
which holds data for every patient added to the normal file, and a Deleted 
Patients folder, which holds patients that have been removed from the file. 
Two XML format files are also created, one which has the name of the 
normal file, such as “testfile.xml”, which holds administrative details such 
as the number of patients in the file and the date it was created, and a 
database file with a similar name, such as “testfile_db.xml”, which holds 
the actual patient data, including the pixel arrays used to construct the 
mean.

If you add patients to the normal file using the Database/Add Patient(s) 
menu option, the database file is immediately updated with the data from 
those patients. However, the administrative file is not updated unless you 
select the Show Normal File button. This option calculates the means and 
standard deviations for the normal file and updates the administrative XML 
file. Show Normal File will also display the means, both as curves and as 
polar maps.

Once the means have been calculated and displayed, the complete set of 
values can be saved to disk as a file. Use Save Means as Textfile from 
the Options menu. Afterward, the file can be opened in any text editor, and 
can also be opened using other applications such as a spreadsheet. See 
Figure 2-30 for an example.

Saving the Database

Saving the Means
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Figure 2-30. A portion of the saved means file, as it appears when opened using a 
spreadsheet program such as (in this example) Microsoft Excel.

Thresholds for abnormality (explained in “Setting Thresholds” on page 32), 
are automatically saved to the administrative XML file as soon as they are 
set. The textfile listing the thresholds is also created automatically.

Any display screen in ENDG can be saved as a JPEG format image to 
disk. Use the Save Screen function under the File menu. The image is 
saved to the directory folder under userNormalFiles that has the same 
name as the current normal file.

Once your normal file is completed, it must be converted into a binary file in 
order to be used with Emory Cardiac Toolbox. There is only one step: 
select the button Export Normal File. The file will have the same base 
name as the normal file itself, with the extension “.nlg”, and will be written 
to the appropriate directory inside the ECToolbox folder heirarachy.

Saving the 
Thresholds

Saving the Current 
Screen

Saving the Normal 
File for ECToolbox
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User-Defined Normal Files in Emory Cardiac Toolbox

Once you have created a normal file and exported it for use in ECToolbox, 
the last step to make the file usable is to set the preference in ECToolbox 
so that the file is recognized.

Using the dialog shown in , perform the following steps:

• Click the Edit button.

• The dialog shown in Figure 2-32 will appear.

• Use the Browse button, and choose the normal file you want to add 
from the list that is displayed. If there are male and female sections 
to the file, you must add them both.

Figure 2-31. Setting up a user-defined normal database in ECToolbox.

A maximum of 6 user normal files can be handled by the current version of 
ECToolbox. If you have more than that, you will have to delete one in order 
to add a new one.
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Figure 2-32. The dialog used for locating a user-defined normal file to be added to 
the ECToolbox list of available files.

Your normal file should now appear in the list of available files in 
ECToolbox’s Study Verify window.
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